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Lab Assignment #5: Introduction to Creo ME 170 

Instructor: Mike Philpott (email: mphilpot@illinois.edu) 

Date Due: One week from Start Day of Lab (turn in deadline – 11pm night before next lab) 

A.  Design Project - 5 minute team presentations  
 5 slides – send powerpoint (ppt/pptx) to your TA by noon of lab day 

 All team members should be present 

 Tell us the story of how you got to now. Who are the main characters? What’s the 

problem they are facing? 

 Initial interviews - Who? Why? Key findings? 

 Follow up interview(s) - Who? Why? Key findings? 

 "Point of view” Statement 

 ”How might we…” questions 

 5 different concept sketches - Explain how each concept addresses the unmet need. 

 

 

B.  First Creo lab. - This lab assignment is designed to get you accustomed to the program's 

interface and to manipulating a part model - without having to create it yourself. You will 

modify the part, examine some aspects of how it was created, and learn some of the basic 

features of using Creo Parametric. Finally you will complete Exercise 1, p.36-40, and then turn 

in your lab assignment electronically. 

 

Part I. EWS login 

1) Login to an EWS computer. 

Type your login name (NetID) and password. You should have received a letter with your 

NetID and initial NetID password. If you cannot log in with this password, you may need to 

reset your AD password. The EWS labs use the UIUC Active Directory (AD) password 

which may different from your NetID password. You can reset your AD password at 

https://passwords.cites.illinois.edu/. If you still cannot log in, ask the operator for help (there 

should be an operator at a desk in the lab). 

 

Part II. Download required base files   

a. Go to the class website and download the CAD files required for this assignment. 

i) Right click "ME170_Base.zip" and select "Save link as...". 

ii) Save the ZIP file to your desktop. 

iii) Notice that the icon for the ZIP file is ever so slightly different from the Windows 

folder icon. The ".zip" file is an individual file, just like a ".doc" file for MS Word or 

a ".exe" file for an application. It is not a folder. Creo may, from time to time, allow 

you to browse within ZIP files and open part files within ZIP files. However, this is a 
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bad practice, and you will not be able to save to the ZIP file. If you would like to 

access or use the files within a ZIP file, you should first unzip that file (instructions 

below). ZIP files are very useful for transferring many files while preserving file 

structure and reducing file size. Even though Windows provides the capability, you 

should not browse and access the contents of a ZIP file as if it were a normal folder. 

b. Extract the ZIP file. 

i) Right click the "ME170_Base.zip" file. 

ii) Place your mouse over the "7-Zip" text and then select "Extract here". 

iii) A folder named "ME170" should appear on your desktop. This will be your main 

directory for this course. 

iv) Delete the "ME170_Base.zip" file from your desktop. 

v) Open the "ME170" folder. Note the preexisting file structure, some part files, and 

some configuration files. You will use these files throughout the course. 

 

Part III. Introduction to Creo 

1) Start Creo Parametric. 

a. Go to the start menu, click on the "All Programs" folder, navigate to the "PTC Creo" 

folder, and select “Creo Parametric 5.0”. 

b. Wait for Creo to open and load.  

2) Set your working directory. 

a. Click "Select Working Directory" under the "Home" ribbon. 

 

b. Navigate to your ME170 folder. Select the computer icon/name (mel-1009-##) in the left 

column of the window. Double click your network directory 

“engr\instructional\your_netid”. Double click “Desktop”. Select the “ME170” folder and 

click “OK”. 

NOTE: You should set your working directory each and every time you open Creo to 

ensure that all your files wind up in the same directory. Once this working directory is 

set, you can open a file simply by selecting "File" → "Open" within Creo. All of your 

files for a lab exercise or project should remain in the same directory. 
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NOTE: Any file saved to your desktop or in your “Documents” folder on a Windows 

EWS machine is actually saved to a network drive (not the hard drive of the local 

computer in the lab). Consequently, your files will be available on any Windows EWS 

machine on campus. (They will not be available on the Linux EWS machines).  

3) Open the 154deg angle bracket in your ME170 directory. 

a. On the top menu toolbar, select "File" → "Open." 

b. Double click on the “bracket154.prt” file to open it. Alternatively, select the file and click 

"Open." 

c. Turn off the bell if activated (too noisy in lab!). Navigate to "File" → "Options." Select 

"Environment" in the left column and uncheck the "Sound bell for prompts and 

messages" box. 

4) Explore the bracket using the various available view options. 

a. Click on the "View" ribbon. 

b. Under the “Model Display” section click on "Display Style" and click on each of the six 

display style options to see how the model display changes. 

 

5) Explore spin, pan, and zoom functions using the mouse and with various view options 

selected. 

a. Hold down the middle mouse wheel to spin the model. 

b. Hold down the shift key and the middle mouse button to pan the model. 

c. Twiddle or spin the middle mouse wheel forward and backward to zoom in and out. (If 

your mouse does not have a wheel, hold the “Ctrl” key and the middle mouse button and 

move the mouse vertically up and down to zoom in and out.) 
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6) Select the default view of the bracket. 

a. Navigate to the "View" ribbon and select "Standard Orientation" from the menu bar 

(image below).  This should return the part to its original view. 

 

7) Display datum tags. 

a. In the "Show" section of the "View" ribbon, toggle "on" the datum tags for planes, axes, 

datum points, and coordinate systems. Each of the four buttons should appear depressed.  

 

b. Notice how the datum plane labels each correspond to an item listed in the "Model Tree" 

in the left column. Note: The datum tags do not display by default. It is often very useful 

to turn them on after opening a model. 

8) Modify the dimensions of the 154deg angle bracket. 

a. Left mouse click on the bracket to select it. 

b. Right mouse click (hold for a second) to bring up a menu. 

c. Click “Edit” in the menu (image below). Dimensions should appear on the bracket. 

 

d. Move the cursor to the 154 degree dimension.  Left mouse click on the "154.00°" text to 

select it. 

e. Right mouse click to bring up a new screen menu. 

f. Select “Value” on the menu. 

g. Change the bracket angle to "90" in the dialog box and hit the “Enter” button.  
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h. Under the “Model” ribbon, select “Regenerate” (image below).  

 

Your model may have already regenerated. In older versions of Creo, regeneration was 

not automatic. It is still good practice to regenerate the model after editing it. 

Regeneration rebuilds the model from scratch on the computer. For complex models, 

even though the model may appear regenerated, certain features may not have 

regenerated. Regeneration ensures that the model is displayed correctly. 

i. Right click the message at the bottom left-hand corner of the screen and select "Message 

Log" from the menu that appears. Read the message log and make sure that 

"BRACKET154 regeneration completed successfully." appears in the log. The bracket 

should now be at 90 degrees. 

It is OK if an additional warning message appears. Creo is alerting us to a possible issue 

with the model. 

j. There are two alternative methods for editing the angle dimension. Take a moment to edit 

the dimension using both of these methods. Your final angle dimension should be 90 

degrees. 

i. After clicking "Edit" in part 'c' above, double click the dimension of interest to edit 

it. After editing the dimension, press enter, and regenerate the model. 

ii. Instead of selecting "Value" in part 'f' above, select "Properties." A new window 

will appear where the dimension value and other dimension properties may be 

edited. After editing the dimension properties, select "OK" and regenerate the 

model. 

9) Repeat the steps listed in section '8' above to change the following dimensions: 

a. Change the 59 side length to 41. 

b. Change the 75 side length to 45. 

c. Regenerate the model to observe the changes. 

10) Perform the following operations: 

a. Select the hole with axis "A1." This is done best by selecting the inner surface of the 

hole. 

b. Edit the 27 length dimension. Change the value to 20. 

c. Repeat for the hole with axis "A2." 
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d. Regenerate the drawing and observe the movement of the holes. 

e. Alter the bracket width dimension from a value of 41 to 80. Note: Be sure to pick the 

bracket width dimension and not the side length dimension, which also has a value of 41. 

See image below. 

 

f. Regenerate the model and note the changes. (Hint: Select each hole and observe the 

dimensions - by selecting "Edit" - used to reference the hole positions.) 

 

g. Write down what happens to each hole in a few sentences. Write your name and 

NetID on a piece of paper with these comments. At the end of the lab session, please 

hand in to your grader along with other comments requested below. 
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11) Use the measure command to measure the distance from the hole center to the four outer 

edges closest to the each hole. Do this for both holes. 

a. On the sheet that you will hand in, make a rough sketch of the two sides of the part. 

The sketch can look like the image below. Give yourself ample space to write dimension 

values. 

 

b. Navigate to the "Analysis" ribbon and click the arrow under "Measure." Select the 

"Distance" option. 

 

c. Pick the center of one of the holes by selecting its inner surface or the axis that runs 

through the center of the hole.  

When dimensioning or measuring, it is best practice to dimension to surfaces and datum 

features (planes, axes, and coordinate systems) since these features are more stable than 

edges. 

d. Hold "Ctrl" and click on any feature to see the distance to the center axis of the hole. 

e. Write down the distance displayed in window that appears. 

f. Repeat this process for the next two edge distance measurements. Be sure to record the 

three requested dimensions for the hole. 

g. Repeat steps 'c' through 'f' for the other hole. 

h. Close the "Measure" window. 
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12) Change the bracket width back from 80 to 41 and regenerate the model.  

13) Change the thickness of the bracket from 6 to 10 and regenerate the model. 

a. The thickness of the bracket is governed by two dimensions. Ensure that both thickness 

dimensions are changed from 6 to 10. 

b. Rotate the part using the spin, pan, and zoom commands (section '5') in order to view the 

inside surfaces of the bracket. 

c. Write down what happens to each hole and why in a few sentences. 

14)  Edit the definition of the blind-depth hole to extend through the entire wall of the bracket.  

Note that the “hole” is considered a feature within the bracket154 part. It is listed in the 

model tree as "Cut id 109."  

a. Select the blind-depth hole either by selecting "Cut id 109" in the model tree or selecting 

the feature in the three-dimensional model. 

b. Hold down the right mouse button and select “Edit Definition" from the drop-down 

menu. 

 

c. Move the cursor to the small depth icon to the left of the dimension window at the top left 

of the screen. Left mouse click on the arrow to see other selections for the hole.  Choose 

the “Extrude to intersect with all surface” option (highlighted in green below). This 

option instructs the extrusion to cut through any surface with which it intersects. 

 

d. To confirm the change, either hit “Enter,” click on the green checkmark near the top-

middle of the screen, or click on the middle mouse button. 

e. Comment on the change to the hole. 

15) Change the bracket thickness back from 10 to 6 and regenerate the part. 
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16) Measure the radii of the rounds on the inside and outside of the bend in the bracket. 

a. Navigate to the "Analysis" ribbon. Click the arrow under the "Measure" tool and select 

the "Diameter" option. 

b. Select the inner and outer rounds record both fillet radii. 

17) Alter the dimension units for the bracket. Change the units from inches to mm. 

a. From the "File" menu, choose "Prepare," then select "Model Properties." Click "Change" 

to the right of "Units." 

b. Select the "Millimeter Newton Second (mmNs)" row and click the "Set…" button. 

c. Click on "Interpret dimensions." 

Note the two options for changing model units! The "interpret dimensions" option 

interprets 1" as 1mm. This is very, very useful if you accidently model a metric part, 

using metric dimensions, with your Creo units set to inches (or vice versa). This option 

makes it easy to correctly change your units.  

The "convert dimensions" option is useful if you are working on a project with both 

metric and English parts. This option allows you to maintain the same spatial dimensions 

while converting between measurement systems. 

d. Click "OK." 

e. Click "Close" in the Units window and "Close" in the Model Properties window. 

18) Save a copy of the new bracket. 

a. Select "File" → "Save As" → "Save a Copy." 

b. In the "New Name" field, type the new part name: "<netid>_bracket90". (Replacing 

<netid> with your NetID. Note that Creo does not allow the bracket characters ">" or "<" 

in the file name.)  

c. Click "OK" to save the part. 

d. Select "File" → "Exit" to close Creo. 

 



Lab Assignment #1  ME 170 

Page 10 of 12  

Part IV. Exercise 1 (pages 36-40 class text book) 

1) Complete Exercise 1 in the textbook to familiarize yourself with working with files in Creo. 

You do not turn in anything from Exercise 1 for credit but you need to understand this 

content or you will have serious difficulty with your files throughout the course! 

The following notes will assist you with completing Exercise 1. 

Task 1 

- All the CAD files you need should be in your ME170 folder if you completed Part 2 

correctly. Set the working directory to this folder using the instructions in Part 3, Section 

2 above. 

Task 3 

- The message area is in the bottom left corner of the screen. The message log can be 

accessed via the instructions in Part 3, Section 8.i. The message log can also be accessed 

in the "Investigate" section of the "Tools" ribbon. 

Task 14 

- Your part will not be created from "template_mm.prt". This is OK. Do not attempt to 

change the configuration options as per the book's instructions. 

 

Part V. Submission Requirements 

1) Hand in your written responses to questions above with your NetID and name 

2) Change your file display settings to select the correct part file for submission. 

Creo creates a new file each time you save a part or assembly. Each of these files has the 

same file name (i.e. "bracket158") and file extension (i.e. ".prt"). In order to keep track of 

the files, Creo adds a version designator after the file extension. This version designator 

is incremented each time you save the part. The first save starts at 1. Year-long projects 

often have files with version numbers in the hundreds. This feature is very useful if you 

need to go back to an earlier version. When opening a part through Creo's file browser, 

Creo automatically opens the most recent version of the part - the one with the highest 

version number - and hides any previous versions.  

Windows, however, interprets the version designator as the file extension and 

automatically hides the number on most Windows machines, making it very difficult to 

determine which file is the most recent version of a part. The following instructions 

unhide the version designator so that you can be sure to submit the latest version of your 

part for grading. 

a. In the windows file browser, NOT the Creo file browser, select "Organize" → "Folder 

and search options." 
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b. In the "Folder Options" window. Navigate to the "View" tab and uncheck "Hide 

extensions for known file types." Click "OK." Notice the numbers that appear after your 

part files. Those numbers are the Creo's version designators. 

     

3) A few very, very important notes regarding your Creo files. 

a. In Lab 2, you will begin to build part files that you will edit and modify for the remainder 

of this course. Follow these guidelines to ensure that your part files open correctly and 

that these files are not lost, deleted, or incorrectly modified. 

i. Keep ALL of your part files, configuration files, drawing files, and any other Creo 

files directly in your ME170 folder, NOT in any folders within the ME170 folder. 

This will look very messy from a file management perspective (hundreds of files in a 

single folder!). However, it is necessary for your parametric model to open and 

function correctly. 

ii. DO NOT create a subfolder for each lab assignment. Keep ALL of your part files, 

configuration files, drawing files, and any other Creo files directly in your ME170 

folder. 

iii. DO NOT edit files in your "Submissions" folder. Edit the files in your ME170 folder. 

The "Submissions" folder is merely a tool to help create ZIP files and retain a record 

of your submissions. Be sure to COPY and paste your files to the "Submissions" 

folder. Do not CUT and paste the files. 

iv. ALWAYS set your working directory, and ONLY open and edit files in your ME170 

folder (which should be set as your working directory).  
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b. Although you may only have one version of each file at the conclusion of this lab, you 

will have multiple versions of each part file at the conclusion of subsequent labs. Ensure 

that you submit the MOST RECENT VERSION of each part file for grading. 

c. If you move your files between computers (eg. to work on the lab at home), it is best to 

move your entire ME170 folder. Attempting to select and move individual files almost 

always results in lost files, incorrect files versions, and general mayhem. 

4) Submit your “<netid>_bracket90.prt.#” part model for grading (where # is the highest 

numbered file you have in your directory): 

a) Login to: https://my.mechse.illinois.edu 

b) If you have not already done this for another class, go to the center bottom of the page 

and select “My Classes” from the ‘Add content to above column’ pull down menu. 

 
 

c) Your registered classes should then appear at the bottom of your my.mechse page in the 

“My Classes” tab. 

d) Go to the ME170 ‘Calendar/Assignments’ column of ‘My Classes’ and click on the 

assignment you wish to submit file(s) to be graded (in this case, “Lab Assignment #1”); 

in the section number of your lab class (AB1 thru 7).  

e) Use the Browse -> Upload buttons to select and submit your file(s) for grading. 

f) Close all of your programs and log off the EWS computer: Click "Log Out" in the start 

menu. Make sure the login screen appears before leaving your workstation. 


