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1 Introduction

In this class, we’ll be using SPICE to simulate our circuit designs. SPICE stands for Simu-

lation Program with Integrated Circuit Emphasis, and is an essential part of modern circuit

design. SPICE comes in many “flavors” like HSPICE, PSPICE, ngspice, and many others,

all of which perform the same front-end function of circuit simluation, but with different

“behind-the-scenes” optimizations. LTspice is a free-to-use SPICE simulator created by Lin-

ear Technologies (now part of Analog Devices), and we’ll be using it for this class. This

document is a reference manual for the various functions and tools in LTspice. As a general

rule, bold text means a keyboard shortcut, whereas monospace text is a menu option.
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2 Keyboard Shortcuts

While you can click through all the menus you like, sometimes knowing the keyboard short-

cuts are faster. These are all for the schematic editor :

F1 - Open the Help menu

F5 - Delete an item

F6 - Copy an item

W - Select the wiring mode

E - Add a net name

R - Add a resistor

T - Add plain text

S - Add SPICE text

D - Add a diode

F - Find/add a part

G - Add a ground port

X - Add an inductor

C - Add a capacitor

Space - Zoom full

Ctrl+W - Move

Ctrl+E - Mirror

Ctrl+R - Rotate

Ctrl+T - Toggle pins

Ctrl+Y - Redo

Ctrl+S - Save File

Ctrl+D - Drag

Ctrl+F - Find text

Ctrl+G - Toggle grid

Ctrl+H - Halt simulation

Ctrl+Z - Undo

Ctrl+X - Delete

Ctrl+C - Copy

Ctrl+V - Paste

Ctrl+B - Run simulation

Ctrl+N - New schematic
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3 Getting Started

Open LTspice by either clicking on the desktop shortcut, or going to Start→Programs→LTspice

XVII. You’ll see Figure 1 upon starting up:

Figure 1: LTspice startup screen. Engineering sketches made out of coffee stains!

Let’s get started by creating a new schematic. Go to File →New Schematic, or hit Ctrl+N,

and the coffee stains should disappear, leaving you with a fresh page. Let’s make our first

circuit, shown in Figure 2. To add the voltage source, press the AND gate symbol (or F)

and search for the voltage part.

Figure 2: Basic lowpass filter schematic.
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You should get the following menu:

Figure 3: Adding components window.

Now we can assign values to all the parts by right-clicking on them. Note LTspice has two

useful features: first, it auto-assigns the units for us, so we can say the resistance is 50 or

50 Ω, it doesn’t care. Second, it implements the SI prefixes, so we can say 4.7n instead

of 0.0000000047. However, it is case-insensitive! 10mΩ is 10 milli-Ω, and 10 MegΩ is 10

Mega-Ω. Just putting 10 M would be interpreted as the milli- prefix, so be careful! As an

example, we chose R1 = 1 kΩ, R2 = 10 kΩ, and C1 = 47 µF. Note we can also choose a

specific “real-life” model, which will come in handy when using active devices.

Figure 4: Editing components window
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Next we’ll set V1. Right-click on it and choose advanced. Copy the values shown in Figure

5, and be sure to also set the small signal values AC values in the right hand side column.

Figure 5: V1 settings.

The different function choices are:

(none) - Just a constant DC output

PULSE - Square wave output (series of pulses)

SINE - Sinusoidal wave

EXP - Exponentially decaying/rising wave

SFFM - Single frequency FM wave

PWL - Piece-wise linear wave described by a set of (x, y) points
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3.1 Netlists

LTspice doesn’t work with our schematic directly, but instead compiles it down to a netlist.

You can view the netlist by going to View →SPICE Netlist. Our example netlist is:

R1 Out N001 1k tol=0 pwr=0

R2 Out 0 10k

C1 Out 0 1u

V1 N001 0 PULSE(5 0 10m 1m 1m 10m 20m) AC 1

Each line can be read as: [Device Type][Device Name] [Connection nodes] [Parameters].

The device type is selected based on it’s first letter, so all resistors must be called R<name>,

similarly all capacitors are named C<name>. Based on the device type, SPICE will then read

the next N “words” as connections. The remaining “words” are treated as parameters.
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4 Simulations

LTspice has five total simulation types: transient, AC, DC, noise, TF, and OP. We’ll only

elaborate on the common ones here, more information about the other two can be found

online. To add a simulation type, go to Simulate →Edit Simulation Command. Once you

have created one, you can right-click on the command to bring the menu back up. The

simulation commands appear as text on the schematic, in the exact same way it would in a

netlist. You can run a simulation by pressing the “running man” icon, or pressing Ctrl+B.

Note only one simulation can be run at a time, but you can have several simulation commands

at once. LTspice will simply ask you when simulation you want to run. While a source can

have multiple simulation properties (e.g., a voltage source can output a PULSE in transient

and a sine wave in AC), only the parameters relevant to the simulation will be used.
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4.1 .op

Operating point simulations are used to quickly measure DC voltages and currents. All

inductors are treated as shorts, and all capacitors are treated as open. It prints out the

voltage at every node, and the current through every device. Our example output is shown

below. Note the capacitor current is not exactly zero due to numerical errors, but can be

treated as zero for all purposes.

--- Operating Point ---

V(out): 4.54545 voltage

V(vin): 5 voltage

I(C1): 4.54545e-018 device_current

I(R2): 0.000454545 device_current

I(R1): -0.000454545 device_current

I(V1): -0.000454545 device_current
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4.2 .tran

In transient simulations, we measure our outputs over time. Figure 6 shows the settings

menu. In this class, you will rarely have to edit anything besides the stop time. The

maximum time-step can be set if your waveforms look “choppy” or piece-wise, instead of

a smooth curve. Starting external supplies at 0 V helps with stability occasionally, but is

generally not needed.

Figure 6: Transient simulation settings.

Figure 7: LTspice plotting window.
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4.3 .dc

In a DC simulation, we are sweeping a DC source as our x-axis, and measuring that effect

on the output. Specify the voltage source by name (V1 in our example) and then give an

increment value. If your output waveform looks too choppy or piece-wise, it is recommended

to decrease the increment size. We can sweep up to three voltage sources at once. We can

also sweep current sources using this simulation.

Figure 8: DC simulation settings.

Figure 9: DC simulation example.
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4.4 .ac

In an AC simulation, we do a small-signal frequency sweep around a certain DC operating

point. Make sure to set the AC small signal parameters in the source, as simply setting a

sine wave will not work. We recommend always using decade with at least 20 points per

decade. By default the magnitude is plotted using a straight line with units on the left-hand

axis, and the phase in a dashed line with units on the right-hand axis. You can right-click

on either axis to it and it’s corresponding lines off.

Figure 10: AC simulation settings.

Figure 11: AC simulation example.
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4.5 Cursors

The default viewer in LTspice can be somewhat difficult to read, so we use cursors to read

precise numbers. Add a cursor by left-clicking on the trace name, above the plot. You can

add two cursors measure (x1, y1), (x2, y2), and (∆x,∆y). To move cursors, use the left and

right arrows, or click and drag.

Figure 12: Cursor example in a transient sim.

Figure 13: Cursor menu (transient output).
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5 Variables + Sweeping

In order to see the effect of sweeping a value and checking the output across a range, we

need to set a parameter as a variable by putting the name in curly braces. Then we add a

param statement in the schematic, specifying any default values and use a .step statement

to sweep through the values. The syntax is:

.param [Name]=[Val] [Name2]=[Val2] ...

.step param [Type] [Variable] [Start] [Stop] [Increment]

You can right-click on the .step line to set options through a menu as well.

Figure 14: .step example.

One slightly annoying fact is the lack of a legend on the plot. In order to figure out which

trace corresponds to which run, we have to add a cursor to the plot. Once you add a cursor,

right click on it to have a pop-up describing the run number and value. To switch between

runs, use the up and down arrows.

Figure 15: Plotting the .step results.
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6 Monte Carlo Simulations

Sometimes we don’t know the exact values we want to sweep, but instead just a range. It is

very typical in circuit design to be given a part with only a certain accuracy, such a 10 kΩ

resistor with tolerance ±20%. This type of simulation is called a Monte Carlo simulation,

where we try to figure out our worst-case output. To do this, we set the parameter using a

the mc function, as shown in the schematic. The syntax is mc(mean, var). This function

will return a random value in the range [mean ∗ (1 − var) : mean ∗ (1 + var)] with a normal

(Gaussian) distribution. To run a MC simulation, we use the .step command, specifically

using the run variable. run is a reserved keyword for LTspice, which acts as a pseudo-random

number generator, so we can deterministically repeat our “random” results.

Figure 16: Monte Carlo simulation example
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7 Exporting + Plotting

While the LTspice plotter gets the job done, it’s not the best thing to include in a report

or printout. Instead, export the data to MATLAB or Python and do the plotting there is

preferred. We’ll give example code here to help you do so for some simple examples. First,

make your plot in LTspice, and go to File→Export data as text. The following menu

will pop up:

Figure 17: Trace export window.

From here you can choose the output data directory as well as which traces and specific runs

you would like to save. By default, it selects whatever is currently plotted in the window. It

will be saved as .txt file.

Important step: Open the .txt and remove any text and symbols such as “(”, “◦”,

“dB”. (They can be easily removed by using the replace function under ”Edit” menu bar

in Notepad.) as shown in figure 18 and figure 19 below.
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Figure 18: Original exported .txt file

Figure 19: Modified exporeted .txt file

After making the modification in the textfile, the .txt file is ready to be used in MATLAB

using the sample code provided in the website.
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Here’s the MATLAB example:

%% Formatting

colordef white;

% Plot with default font size 16+

% Linewidth of 2 or 3

set(0,‘defaultAxesFontName’, ‘Arial’);

set(0,‘defaultTextFontName’, ‘Arial’);

set(0,‘defaultAxesFontWeight’, ’Bold’);

set(0,‘defaultTextFontWeight’, ’Bold’);

set(0, ‘DefaultTextFontSize’, 18) ;

set(0, ‘DefaultAxesFontSize’, 16) ;

set(0, ‘DefaultLineLineWidth’, 3.5) ;

set(0, ‘DefaultStairLineWidth’, 3.5) ;

set(0, ‘DefaultAxesLineWidth’, 2.5) ;

set(0, ‘DefaultPatchLineWidth’, 2) ;

set(0, ‘DefaultAxesXGrid’, ‘on’) ;

set(0, ‘DefaultAxesYGrid’, ‘on’) ;

set(0, ‘DefaultAxesBox’, ‘on’) ;

set(0, ‘DefaultFigurePosition’, [200 175 1000 600]);

%% Plotting

filename = ‘directory\ltspice.txt’;

data = dlmread(filename, ’’, 1, 0);

freq = data(:,1);

complex = data(:,2)+i*data(:,3); %convert data into complex + j*real

magvv = abs(complex); % magnitude of AC response in V/V

magdB = 20*log10(magvv); % magnitude of AC response in dB

phase = angle(complex)*180/pi;

subplot(2,1,1)

semilogx(freq,magdB)

title(‘AC Response of 1st-order RC filter’)

ylabel(‘Magnitude (dB)’)

subplot(2,1,2)

semilogx(freq,phase)

xlabel(‘Frequency (Hz)’)

ylabel(‘Phase (deg)’)
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In Python, there’s a couple ways of doing the formatting. The simplest way is to go to your

.matplotlib folder and add a style. Save this as “ece343.mplstyle”.

# ECE@Illinois Configs
# Created on Tue Dec 6 2016
# Fonts
font.family : sans-serif
font.sans-serif : Arial
font.weight : bold
font.size : 18.0

# Axis Tick Settings
xtick.major.size : 16.0
ytick.major.size : 16.0
xtick.major.width : 4.0
ytick.major.width : 4.0
xtick.major.pad : 12.0
ytick.major.pad : 12.0
xtick.labelsize : 22.0
ytick.labelsize : 22.0
xtick.color : k
ytick.color : k

# Marker and Line Settings
legend.numpoints : 1.0
markers.fillstyle : full
lines.markeredgewidth : 2.0
lines.linewidth : 3.5
lines.markersize : 20.0
patch.linewidth : 3.5
grid.linewidth : 4.0
grid.alpha : 1.0
grid.color : #BFBFBF

axes.titlesize : 28.0
axes.titleweight: bold

https://matplotlib.org/users/style_sheets.html
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axes.labelsize : 24.0
axes.labelweight : bold
axes.linewidth : 4.0
axes.grid : True
axes.edgecolor : k
axes.facecolor : w

figure.figsize : 10, 6
figure.facecolor : w

Then the plotting is quite similar to MATLAB: (NOTE: the plot settings below will not give

the same plots in MATLAB version. The code provided below is purely for guidelines)

import numpy as np
import matplotlib as mpl
import matplotlib.pyplot as plt
mpl.style.use(’ece343’)

filename = ‘RC_Filter.txt’
data = np.loadtxt(filename, delimiter=‘\t’, skiprows=1)

time = data[:, 0]
vin = data[:, 1]
vout= data[:, 2]

plt.plot(time, vin)
plt.plot(time, vout)
plt.legend([’Vin’, ’Vout’])
plt.show()

plt.xlabel(’Time [ms]’)
plt.ylabel(’Voltage [V]’)
plt.tight_layout()
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